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Adobe Dreamweaver  
Adobe dreamweaver is a powerful program for 
designing, planning and creating a website. It is a 
complete website production and management tool. In 
this you do not have to write lines of code 
(programming) for making any control on the web. It 
also gives you a graphical editing environment to 
create websites, web applications and webpages. In 
addition it allows you to edit code in the code view as 
per your requirement. Adobe dreamweaver cs3 works 
with web technologies like HTML, CSS and Java 
script.  
Interface and over view of the Adobe dreamweaver 
window  
Start -> All programs -> Adobe web premium CS3-> 
Adobe Dreamweaver CS3 

Interface 

Dreamweaver provides you with the facility to add and 
modify elements of a webpage. When you launch 
Dreamweaver, the start screen appears in the main window. 
From the start screen you can choose to create a new page 
from one of the many of the Dreamweaver sample files. 

 
 
 

Menu bar, Title bar, Insert bar and the Document tool bar  
Title bar 

 
Title bar gives you the clue of the program that is running on your computer along the name of 
currently opened file and name of the software manufacture 2 

Menu Bar 

 

A horizontal bar with menus just below the Title bar is known as the Menu bar. Each menu on menu 
bar contains commands to accomplish tasks based upon the menu name. 

Inset Bar 
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Insert bar contains buttons for creating and inserting objects like Tables, AP elements and images. 
The insert bar is at the top of the document, which has a number of buttons for specifying how 
dreamweaver operates 

Document Bar 

 

 

The document window is the main working area in dreamweaver where the user writes codes to 
create a website. If you use the designer interface in Design view, you see your page as it would 
appear in a web browser. If you want to see the HTML code behind your page, click the code button 
at the top of the work area. Choose the split button to see the HTML code and Design view 
simultaneously. 
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Properties inspector (window) (Ctrl+F3)  
Select Window menu -> select properties inspector or Press Ctrl+F3 (keyboard) 

 

Properties inspector displays the attributes of the currently selected item on the page, whether it is an 
image, a piece of text, a table or a frame. They can also be altered by entering values within the 
properties inspector. For eg. If you want to change the size of an image, you can select it and then 
enter the new size in the properties inspector. Similarly, buttons, text box, image and many more 
elements in dreamweaver have their own attributes which are displayed in the properties inspector. 

Homepage / Index page  
To create a new page go to File > New and choose a basic HTML page. Save this page by clicking 
File > Save As. Name the first page index.html. This will be the first page that users encounter when 
they visit your site. Naming the homepage ‘index.html’ tells the Web browser that this is the first 
page it should open when someone visits your site.  
Index page consists of Text, Navigation buttons, Table, frame and images. This is the main page for 
the entire website. It also connects different webpages within the website, email, different website 
and images. 

 

Creating new webpages (Ctrl+N)  
Dreamweaver offers a flexible environment for working with a collection of a variety of documents. 
It also allows you to create new webpages using the blank page or a template 

File -> new -> Blank page -> HTML-> create 
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Elements of the Website  
 
1. Navigation system: This enables the user to move to the main areas within in the site  
2. Hyperlinks : These allow users to connect to other pages, website, or email within the site or to 
other site on the web  
3. Main content: This should be designed for presentation on screen.  

 

Types of websites  
 Personal sites: These are the sites created by individuals and contain details of their personal 
information.   Eg: Berners –Lee http://www.w3.org/People/Berners-Lee/  
 Small business sites: These sites are intended to promote small and local business. They are 
frequently created by the people involved with local or small business. This site should be clear, 
concise and give the user all of the details that they require. Eg: DRCC sites http://www.drcc.co.uk/  
 Large Business sites: These are professionally designed sites that contain information about 
the company, it products and services and how to part with the money. Eg: Adobe sites 
http://www.adobe.com/  
 Online business site: These are the sites that are run by business that only have online 
presence. They tend to be e-tailers or multi channel sites or cover topics such as entertainment or 
sport. Eg: www.amazon.co.uk, www.yahoo.com 
 
Guidelines for creating a website  
Before starting your web pages it is a good idea to write down some guidelines for the production of 
your webpage. This can be used as a framework around which an effective and consistent site can be 
created. The best way to formulate guidelines is to look at websites and see the elements and styles 
that you would like to incorporate into your own. 

Some areas to consider for your guidelines include:  
 Fonts/Text: Identify font styles, sizes and colours to be used  
 Headings : Specify font, size, and colours for main headings  
 Background: specify the colours and image to be used, if any  
 Format: Specify how the page is going to be formatted i.e. the size and position of tables, 
texts, images etc. within the site  
 Image: Specify details about how images are to be used in relation to their file size  
 Additional features: Decide whether your pages are going to contain items such as frames, 
tables, flash buttons, animations, date and time etc.  
  

http://www.yahoo.com/
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Creating a site structure  
 One of the factors that enable all of the pages on the 
WWW (World Wide Web) to be connected together, it is 
important to create a file structure for your own website 
before you begins authoring the pages. Initially this will 
consists of a new folder or directory, which is known as the 
root folder, as all of the subsequent folders and files will 
branch off from it. Once the root folder has been created, sub 
folders can then be added. 

When you come to creating the individual pages, make sure they are saved into the relevant folders 
within the structure 

Writing for the web  
One of the most common mistakes made when people are preparing text for webpages is that they 
think it is just a question of reproducing the same style as they would for a copy publication.  
Some of the techniques that can be used to overcome these problems are:  

 Rewrite passages of text so that they are shorter and more concise  
 Use plenty of headings and subheadings. This helps to break up the text and provide the reader with a 
good content of the passage.  

 Convey important points using numbered lists of bullet points  
 Split long passages of text by putting them of several pages  
 Include summary information in boxes within the text or in the on screen margins  
The good and bad website  
When good and bad examples of how text is used on the web are viewed together it is clear to see 
how important it is to take some care and effort when writing for the Web. 

The text here is far too tightly packed together and there is not enough white space around it. Also it 
appears as on large paragraph and is not broken up in any way.  

 

Subheading and lists break up the text 
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Using image on a website  
 
Photographic / Graphical images are one of the best ways to capture peoples/users attention on a 
website.  
Guidelines for using images in a website  
If possible resize image before they are placed on a webpage. This can help reduce the overall size of 
image and also the downloading time.  
Capture digital images (photo) at a low resolution.  
Use thumbnails. These are reduced version of the original image. If they (thumbnail) are used on a 
webpage, a hyperlink can be used to allow the user to access a larger version of the image.  
 
Inserting Images (Ctrl+Alt+I)  
 
To insert an image, follow these steps:  
1. Click in the cell where you want the image to appear.  
2. Click Insert > Image.  
3. Locate the image you want to insert.  
     NOTE: All of your images should be saved in the folder that you created when you started.  
4. Click Choose to insert the image.  
Click on the image to view the Image Properties Inspector window 

 

The top half of the Image Properties Inspector 
allows you to:  
• Name the image.  
• Change the size of the image (W&H).  
• See where the image file is located (Src).  
• Link the image to a file or a site (Link).  
• Edit the image (Edit). 

 

Formatting page properties Ctrl+J  
To change the background color of your pages or 
other overall properties of your website, go to 
Modify > Page Properties. 
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Table Ctrl+Alt + T  
 

A Table consists of three basic elements: rows, columns and cells. You can insert any type of content 
in a cell such as images, text and multimedia files. Using the properties inspector in the dreamweaver 
window you can merge and split cells add colour to the background or borders and you can also 
change the alignment of the cell. Table can be used to create like a similar effect to frames. 

Inserting a table  
To insert a table, follow these steps:  
1. In the main menu, click Insert > 
Table.  
2. Insert the amount of Table Rows and 
Columns  
3. Set Table width to between 600 and 
800 pixels.  
4. Set Border thickness. To have a 
visible border type in 1 or higher, to have 
no  
border type in 0.  
5. Cell padding adds room inside of a 
cell. Enter 0 for no space or a number to  
Increase the space.  
6. Cell spacing adds space between cells. 
Enter 0 for no space or a number to  
Increase the space.  
7. Click OK.  
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Properties of a Table 
If you click on one of the table borders, you can view your table properties in the Properties 
window. 

 
Properties of Cells inside Table  
Once the properties of the table have been set, you can also adjust the properties of individual cells 
within the table by clicking inside the cell. 

 
• Merge and split cells  
• Change the alignment of the content horizontally and vertically.  
• Change the width and the height of the cell  
• Use Wrap.  
• Insert a background image / colour for the single cell.  
• Change the border color for the single cell. 
 
Here is an example of a page with a background color selected for the page, for each table, and for 
some specific cells in each table 

 
Now you can adjust the table by clicking and dragging on the 
handles to make the table look more like a familiar webpage 
frames  
From here you can insert additional tables into any of the 
cells you want. This will let you place your text and images 
exactly where you want them within each section. 
Adding text in a cell  
To insert text simply click inside a cell and type in your 
content. When you click  
ENTER, Dreamweaver automatically adds paragraph spacing. To add a line space,  
click SHIFT + ENTER. 
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HTML: Hyper Text Markup Language  
HTML files are plain text files and they do not contain any actual images or multimedia effects. 
HTML file can be created in text editors such as Note pad. When the file is being created all that will 
be visible is text and the HTML tags. These files have to save with ‘.htm’ or ‘.html’ file extension. 
 
Flash button: is used to organize the index file more precisely. It is also giving the facility to 
connect another webpage/ image/email/website. 
 
Hyperlink  
 
A hyperlink or link, is an object or text that, when clicked, takes the users to another webpage or 
opens a file.  
The various types of hyperlinks are explained below.  
 
Internal Links  
 
Internal links are used to connect users to other pages within the same website. (Before linking to 
other pages, you must make sure that the other pages are saved contain the file extension .htm or 
.html.)  
To create an internal link, follow these steps:  
1. Select the text or image you would like to make a hyperlink.  
2. Click on the small folder next to the Link field in the Properties Inspector  
3. Browse through the files, and select the page you would like to link.  
4. Click Choose. 
 
Text link  

 
 
Image link  
 

 
 
External Links  
 
External links are used to connect the users to pages from other websites. To create an external link, 
do the following:  
1. Select a text, button or an image you want to make a hyperlink.  
2. Click on the Properties Inspector. 
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3. Type the complete URL (web address) of the website you want to link (e.g. 
http://www.google.com).  
4. Select the Target type as –blank (it will open the link in a new window) 
 
Links to Files  
 
Sometimes you may need to link a file such as a PDF, a Word document, or a PowerPoint 
presentation. When the user clicks the hyperlink, the files will either automatically open up in its 
original program or the browser will prompt the user to save the file on their hard drive.  
To create a link to a file, follow these steps:  
1. Make sure that the file you want to link is saved in your folder.  
2. Select a text or an image you would like to make a hyperlink.  
3. Click on the small folder next to the Link field in the Properties Inspector  
4. Browse through the files, and select the file you would like to link.  
5. Click Choose.  
6. Select the Target type as -blank.  
 
Email Link  
 
E-mail links are links that will automatically open the user's default email program with a blank e-
mail addressed to the specified e-mail link.  
There are two ways to create an email link. You can:  
1. Click on the Insert menu at the top of the screen and select Email Link.  
2. Type in text for the hyperlink name or label, for example: My Email or Click here to email me  
3. Type in your email address, i.e. where the email is to be sent.  
4. Click OK. 
 

 
 
 
 

/*****************END OF TERM 1 *****************/ 


